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1.0 Getting Started 
1.1 How to Import a Spatial Dataset into your Project 
To start working with a dataset in the QGIS map view, go to the Browser Panel and navigate to 
the folder where your file exists. If you cannot see the browser panel, in the top menu ribbon 
go to View > Panels > Browser. The browser panel should now be in the left-hand side of the 
interface. 

 

1. Drag and drop the file into the QGIS map view and it will appear. You can also now find 
the layer in the Layers panel 

2. Alternatively, you can also add spatial data by dragging files into the QGIS map view 
from your computer’s file explorer 

 
 
 
 
 

Layers 
Panel 

Browser 
Panel 

Note: this method will only work for shapefile (.shp), geopackage (.gpkg), KML (.kml), 
geodatabase (.gdb), GPS Exchange Format (.gpx) but NOT for a comma-separated 
values (.csv) files. For shapefiles, only the .shp file needs to be dragged in, not all the 
files associated with it. 
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1.2 How to Import a Spreadsheet into your Project 
You can import spreadsheet data into your QGIS project. In the top menu ribbon, go to Layer > 
Add Layer > Add Delimited Text Layer.  

 

In the Data Source Manager > Delimited Text menu, 
1. Click the ellipses beside the ‘File name’ field. Navigate to where your file is located in 

your computer and select it. In the ‘Layer name’ field, the file name will appear 
2. Under the ‘File Format’ section, select the format that corresponds to your data. This 

will most likely be CSV (comma separated values) 
• For the ‘Custom delimiters’ option, select how values in your data file are 

separated 
3. The Geometry Definition section will be automatically filled in if coordinates are 

detected 
• The ‘Point Coordinates’ option will be selected if longitude, latitude coordinates 

are detected in your file. Ensure that the correct attributes that correspond to 
the X field and Y field are selected (i.e. X = longitude or easting, Y = latitude or 
northing) 

• The ‘No geometry’ option will be selected if no coordinates are detected 
4. In the ‘Geometry CRS’ option, the default option should be selected if longitude, latitude 

coordinates are being used 
• If longitude, latitude coordinates are not being used, select the correct CRS for 

your project (e.g. UTM) 
5. In the ‘Sample Data’ window, check to see that the layout of the data is correct 
6. Click ‘Add’ 

 
The new layer should now appear in the QGIS map view, and in the Layers panel. 
 
Note: If your coordinates appear in the wrong location, double-check that the coordinates are not 
reversed. Longitude/easting must be the X coordinate and latitude/northing must be the Y coordinate. 

Note: the spreadsheet must be in .csv format, and not .xlsx 
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1.3 How to Save a Spatial File 
Save your temporary scratch layer so it is accessible for future projects. To do so, in the Layers 
panel, right-click on the layer > Export > Save Features As… 

  

 
 
 

 
In the Save Vector Layer as… menu, 

1. In the ‘Format’ field, select the desired file type (e.g. ESRI Shapefile, geopackage) 
2. In the ‘File name’ field, click on the ellipses then navigate to the project folder 
3. In the ‘CRS’ field, select the projection you want. Usually it will be EPSG:3005 -NAD 

83/BC – Albers 
• If you only want to export certain features of a layer, export the file as above, 

and ensure that the ‘Save only selected feature’ box is checked  
 

4. Click ‘OK’ 

The new file should now appear in your project folder.  
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1.4 How to Add a Web Map Layer 
It is possible to add base map layers into your project from the web. An easy way to do this is 
with a plugin called QuickMapServices. To install this plugin, navigate to the menu ribbon near 
the top and go to Plugins > Manage and Install Plugins. 

 

 

 

 

 

1. In the Plugins menu, type 
“QuickMapServices” into the 
search bar, and select the 
plugin 

2. Click ‘Install Plugin’  
3. To import a web map layer into your project, go to the top menu ribbon and then Web > 

QuickMapServices. You can then pick a webmap server and import one of their base 
maps by clicking on it 

• If you would like a wider selection of base maps, go to the QuickMapServices > 
Settings > More Services. Then, click the ‘Get contributed pack’ button. Click 
‘Save’. This will add a far greater variety of base maps that you can import 

Once a base map has been imported, you will able to see it in the Layers panel, as well as the 
map view.  
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 

Note: In the QuickMapServices search window, layers are given a red/yellow/green dot 
indicating whether they are currently working. This notation system is not reliable (some red 
layers will work, while some green layers will not work). Also, some base layers are unable to 
load or print. 
Recommendation: Use the Open Street Map (OSM) base map layer for general location, and 
Bing Aerial for a satellite base map layer. 
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1.5 How to Create a Print Map 
Use the Print Layout to print or save your map as a pdf or image file and add elements such as a 
legend, scale bar, and information boxes. 

From the top menu ribbon, select Project > New Print Layout (or Layouts if you are opening an 
existing layout). 

Enter a unique name for the new print layout (this is not a separate file, it is stored within the 
QGIS project). 

1.5.1 Add Map Elements 
Use the tools on the left-hand toolbar to add elements to the print canvas. Select a tool, click 
on the canvas and hold left-click down to draw a box for the element.  

 

 

1.5.2 Set Page Size 
Change the paper size of the map by right-clicking in the canvas, select Page Properties and 
choose the page size in Item Properties. 

  

Add a new map 

Add an image 

Add a text element 

Add a legend 

Add a scale bar 

 

Add an attribute table 

Set layer visibility 

Items Panel 

Item Properties 
Panel 
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1.5.3 Format Map Elements 
Map 

Add/select a map element with the select tool or in the Items panel. Use the Item Properties 
panel to: 

• Set the map scale manually 
• Rotate the map 
• Set the print map to map canvas extent 
• View extent of the print layout in map canvas 
• Add a grid overlay 
• Change the position and size 
• Add a border line (frame)  
• And more! 

Legend 

Add/select a legend element with the select tool or in the Items panel. Use the Item Properties 
panel to: 

• Add a title 
• Customize legend items, fonts, and layout 
• Add a border line (frame)  
• Add a background 
• And more! 

 

 

  

Un-select this 
checkbox to make 
changes to the 
legend 

Use arrows to 
adjust drawing 
order of legend 
items 

Group legend 
items  

Add/remove 
legend items  

Double-click to change 
legend item text  

Filter legend items 
by map content  
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Scale Bar 

Add/select a scale bar element with the select tool or in the Items panel. Use the Item 
Properties panel to: 

• Set the scale bar style 
• Set the units and labels 
• Define the number of segments and segment size 
• Change the display, fonts and colours 
• And more! 

North Arrow 

Add an image element to the print canvas. Under the Item Properties panel, scroll down and 
expand Search Directories and select desired image. Alternatively, you can upload your own 
SVG image or picture file.  

  
Format Text Element 

Add/select a text element with the select tool or in the Items panel. Use the Item Properties 
panel to: 

• Change the content (Main Properties) 
• Change the font and text alignment 
• Add a border line (frame)  
• Add a background 
• And more! 

1.5.4 Export and Print 
Click on the save as pdf icon on the top ribbon or select Layout > Export as pdf… 

Or click on the save as image icon on the top ribbon or select Layout > Export as Image… 

Print the map from a pdf or image export file. 
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1.6 How to Create a Georeferenced PDF Map 
Georeferenced PDFs (for use in Avenza Maps and similar programs) can be created in QGIS 3.x 
(but not in QGIS 2.x). Currently, georeferenced PDF creation is supported on Windows but not 
on Mac OS.  

 

1. To create a georeferenced PDF map in QGIS 3.x on Windows, create a print layout as 
normal.  

2. When the layout is complete, choose ‘Export as PDF…’ and save the layout.  
3. The PDF will automatically be created with embedded location information and can be 

transferred to a field device and imported into Avenza Maps.  
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2.0 Working with Projections 
2.1 How to Set the Projection for a Project 
To set the projection for a project, in the top menu ribbon go to Project > Properties and in the 
Project Properties menu > CRS. Alternatively, click on the CRS box at the bottom of the main 
window to bring up the projection properties panel. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1. Use the ‘Filter’ to find your desired projection 
 

Usage Projection 
ESI Default EPSG:3005 NAD 83/ BC Albers 
UTM EPSG:26909 NAD83/UTM Zone 9N 

Web Mapping EPSG:4326 WGS84 or EPSG:3857 WGS84/Pseudo-
Mercator 

GPS Lat/Long EPSG:4269 NAD83 
 

2. Alternatively, you can search for a projection under the ‘Coordinate reference systems 
of the world’ window; select the projection that you would like to use for your project 

3. Click ‘Apply’ and then ‘OK’ to save your changes 
 
The project should now have a new global projection. 
 

 
Note: Changing a project projection does not change the projection of its layers. It only makes 
layers appear in the project projection, and the underlying data is not reprojected. To change the 
projection of a layer, see Section 2.2. 
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2.2 How to Save Layers in a New Projection 
In order to perform geoprocessing with multiple vector layers they must be in the same 
projection. To fix this, go to the Layers panel to export your layers into the same projection. 

1. Right-click the layer with the projection you wish to change 
2. Select Export > Save Features As 

 
3. In the Save Vector Layer as... menu, click the ellipses next to the ‘File name’ field and 

define your new layer in your project folder 
4. In the ‘CRS’ field, select the desired projection for the new layer 
5. Click ‘OK’ and the new layer will be generated in the Layers panel 

 

 

 

 

 

 

 

 

 

 

  

Note: If you right-click a layer and select Properties, and in the Layer Properties menu > 
Source, under ‘Geometry and Coordinate Reference System’, there is a ‘Set source 
coordinate reference system’ field which allows you to select a new CRS for the layer. This 
option should be used when an imported layer’s projection has not been read correctly 
(which often results in the layer not appearing or appearing in the wrong place on 
import). It does not reproject the layer and is not the correct option if reprojection is 
needed. 
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3.0 Common Geoprocessing Tasks 
3.1 How to Clip Vector Layers 
Clipping allows you to “cut out” a new layer in QGIS using two vector layers: an input layer and 
an overlay layer. To analogize, imagine cookie dough and a cookie cutter. The input layer is the 
dough, while the overlay layer is the cutter, and the new resulting clipped layer is the cookie. 
To access the Clip tool, in the top menu ribbon go to Vector > Geoprocessing Tools > Clip. 
 

 

 

 

 

 

 

 

 

 

 

 

 

In the Clip menu, 

1. In the ‘Input layer’ field, select the layer that you wish to clip (“dough”) 
2. In the ‘Overlay layer’ field, select the layer that you wish to clip with (“cutter”) 
3. In the ‘Clipped’ field, you have the option to save your new file or create a temporary 

layer (default) 
• If you wish to save the new output layer into your project folder, click the 

ellipses to the right of the input box, and select “Save to File...” to do so 
• The default option will output a temporary layer. These layers must be made 

permanent or else they will be lost when the project is closed 
4. Click ‘Run’, and the new layer will be generated in the Layers panel 

• If you encounter an error with the clipping, check if the layers are in the same 
projection. If not see Section 2.2 on how to save the layer in a new projection 
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3.2 How to Add a Buffer to a Vector Layer 
Buffers are spatial boundaries around points, lines, or polygon shapes. Buffers can be helpful 
for determining whether one feature is within a certain distance of another feature, which is a 
very useful analytical tool. To add buffers, in the top menu ribbon select Vector > 
Geoprocessing Tools > Buffer. 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1. In the Buffer menu, select an input layer containing the features that you would like to 
buffer 

2. In the ‘Distance’ field, type in a distance and select a unit for how great the buffer zone 
will be (i.e. distance from…) 

3. The ‘End cap style’ and ‘Join style’ are stylistic choices  
4. Check the ‘Dissolve Result’ option. This will result in a buffer zone that is unsegmented 
5. Under the ‘Buffered’ field, the default option will output a temporary layer. These layers 

must be made permanent or else they will be lost when the project is closed. 
• If you wish to save the new output layer into your project folder, click the 

ellipses to the right of the input box, and select “Save to File...” 
6. Click ‘Run’ 

The Buffered layer should now appear in the Layers panel, as well as in the map view. You can 
rearrange the order of the layers to show the original feature within its buffer zone.  
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4.0 Working with Spatial Data 
4.1 How to Select by Feature 
You may want to perform operations or analyses on a subset of features in your layer, which is 
possible by selecting them. 

4.1.1 Select by Feature Using the Tool Bar 
Ensure you have the layer of interest highlighted in the Layers panel and click the ‘Select 
Features by area or single click’ button > Select Feature(s) in the tool bar. 

  

1. Click features in your Layer to select them. The features will be highlighted once you do. 
Shift + click to select multiple features 

2. To select multiple features quickly, go to ‘Select Features by area or single click’ button > 
Select Features by Polygon 

 

• In the map view, click a spot to set a point of the polygon capture-area. When all 
desired features are within the polygon capture-area, right-click to highlight the 
selected features 

3. To select all features, in the tool bar, click the ‘Select all Features’ button 
 
 
 
 

4. To deselect all features, in the tool bar, click the ‘Deselect Features from All Layers’ 
button 
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4.1.2 Select by Feature Using the Attribute Table 
Go to the ‘Open Attribute Table’ button located in the tool bar. The attribute table will open. 

 

 
 

 

 
 

 

 
 

 

 
 

 

1. Click on the row indices. The row will now be highlighted in blue in the attribute table 
and will also be highlighted in the map view. Shift-click to select multiple features 
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4.1.3 Select by Feature Using Values or Expressions 
To select features according to their attribute values, in the tool bar, go to the ‘Select Features 
by Value’ button. 

 

 
 

 

 
 

 

 

 
 

 
 

 

1. In the ‘Select Features by Value’ menu, there is a field for each attribute in the layer.  
2. Customize the criteria for the desired features by entering values into the attribute 

fields, and using the drop-down menus beside them to pick operators 
3. Click ‘Select Features’ to select the features that contain the desired values 
4. For more customized selections using attribute values, you can also use the ‘Select 

Features by Expression…” option 
 

 
 

 
 

 

 
5. In the ‘Select by Expression’ menu, you can enter in expressions that capture your 

desired features in the Expression window 
• In the example below, features with areas between 200 and 400 are being 

selected 
• To quickly input attributes into the Expression window, go to Search Window 

> Fields and Values to find a list of all available attributes in the layer 
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6. Click ‘Select features’ to select the features captured by the expression 

 
 

The features should now be highlighted in the map view. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  

Note: There are many expressions you can build. Go to 
https://docs.qgis.org/2.8/en/docs/user_manual/working_with_vector/expression.html to 
learn more about building expressions. 
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4.2 How to Style Layers 
Styling allows you to visually highlight important findings within your data layer. Below are 
some simple styling techniques to help you with this. To style a layer, double-click on the layer 
you wish to alter in the Layers panel, or right-click the layer > Properties. In the Layer Properties 
menu > Symbology, 

4.2.1 Changing How a Layer is Displayed 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Select ‘Single symbol’ in the drop-down menu at the very top 
2. In the window below, click on the Symbol layer type line beneath the ‘Fill’ option 
3. In the ‘Symbol layer type’ field, select the type of fill. Different fill options will result in 

different colouring patterns/stylistic effects. Each symbol layer type has further options 
for customization 

4. After altering options to your liking, click ‘Apply’ and then ‘OK’ to save your changes 

The appearance of the layer should now be changed in the map view. 
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4.2.2 Categorized Styles 
Categorized styles allows you to display all unique values of an attribute. 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. Select ‘Categorized’ in the drop-down menu at the very top 
2. In the ‘Value’ field, select the attribute whose values you wish to colour 
3. Click ‘Classify’ to generate the list of unique values for the selected attribute 
4. Alter the appearance of each unique value by double-clicking them 
5. When satisfied, click ‘Apply’ and/or ‘OK’ to apply the changes 

The layer should now appear with its categorized styles in the map view. 
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4.2.3 Graduated Styling 
Graduated styling is best utilized for numerical attributes and shows the geographical 
distribution and range of values present in the dataset. Graduated styling can also be used to 
apply thresholds to datasets.  

 

1. Select ‘Graduated’ in the drop-down menu at the very top 
2. In the ‘Column’ field, select the attribute whose values you wish to colour 
3. Click ‘Classify’ to generate the list of unique values for the selected attribute 

• By default, the data will be divided into 5 equal classes based on the range of data 
values 
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4. You can customize the graduated style or use it to apply thresholds to a data layer. For 
example, 
a) Change the number of classes to 3 
b) Change the values of the classes (double-click on the Values) 
c) Rename the entries under Legend for each threshold range 
d) Change the colours for each threshold (double-click on the colour square to open 

the colour panel) 
• Note that the Legend will not automatically update when the values are changed 

      5. Click ‘Apply’ and ‘OK’ to save and exit 

The layer should now have a graduated style in the Layers panel. 

 

a) 

b) c) 

d) 
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4.2.4 Styling Using Expressions 
You can also style a layer based on expressions. Expressions allow you to group features into 
categories based on their attribute values. 

1. Select the ‘Rule-based’ option in the drop-down menu at the very top 
2. Click the green ‘+’ button near the bottom to add a new rule 

a. In the dialogue box that pops up, for the ‘Label’ field, type in the name of the 
rule that you wish to define 

b. In the ‘Filter’ field, type in an expression to group relevant values under this 
rule 

c. The ‘Else’ option allows you to define a rule to group all remaining features 
not belonging to a defined rule 

d. In the ‘Description’ field, you can provide an explanation for what the rule 
does 

e. The ‘Scale range’ option may be selected if you wish to set when the symbols 
will display depending on the scale of the map 

f. Check the ‘Symbol’ box to assign a symbol to this rule. You can add additional 
markers for the same rule with the green ‘+’ button. Note that you can only 
use one marker at a time 

g. To further customize the appearance of symbols, scroll down the dialogue 
box for more formatting options 

3. Click ‘OK’ to generate the new rule 
4. To edit an existing rule, click the rule and click the ‘Edit current rule’ button near the 

bottom of the window 
5. To delete an existing rule, click the rule and click the ‘Remove selected rules’ button 
6. To change the styling/colour of the rule symbols, you can also select the rule from the 

Layers panel to open the Symbol Selector menu 
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4.2.5 Adding Labels 
You can also add labels to features. To add labels, double-click the layer in the Layers panel to 
open the Layer Properties box. Then, go to Layer Properties > Labels. 

 
 
1. In the drop-down menu at the very top, select ‘Single labels’ 
2. In the ‘Value’ field, select the attribute that you wish to label 
3.  Further label customizations are available in the list selection on the left-hand side  

• Under the ‘Text’ customization, you can perform common text alterations 
such as changing the labels’ font, style, size, colour, and opacity 

• Under the ‘Buffer’ customization, you can create a coloured text buffer to 
highlight the labels 

• Under the ‘Placement’ customization, you can change the location of the 
labels relative to their features 

4. In the ‘Text Sample’ box, you can preview the Label styling 
5. After altering labels to your liking, click ‘Apply’ and ‘OK’ to save your changes 

The labels should now appear in the map view. 
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5.0 Editing Spatial Files 
 

 

 

5.1 How to Edit Values in an Attribute Table 
To edit the values of attributes in a spatial file, with the layer selected, go to the ‘Open 
Attribute Table’ button near the top, or right-click ‘Open Attribute Table’. The attribute table 
will open. 

  

 
 

 

 
 

 

 
 

 

 
 

 
 

1. Click the ‘Toggle editing mode’ button 
2. Double-click on a value in the desired column, and type in a new value, then hit Enter 
3. Re-click the ‘Toggle Editing Mode’ to re-toggle editing mode to save changes 

 
The value of that attribute has now changed. 
 

 
 

 

 
 

 

  

WARNING – This process will permanently change your data layer once the changes are 
saved. Make a new version of any permanent or base data layers you are working with 
before making any of these changes to avoid overwriting the original data layers. 
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5.2 How to Rename an Attribute 
You can change the name of an attribute in your shapefile for better readability or usage. In the 
Layers panel, right-click the layer whose attributes you wish to change, and > Properties. 

 

 

 

1. Go to Layer Properties menu > Fields (on the left) 
2. Click the ‘Toggle Edits’ button at the top 
3. In the ‘Name’ column, double click on one of the attributes. You can then change the 

name of the attribute by typing it in 
4. Click ‘Apply’ and then ‘OK’ to save your changes 

You can check that the name of the attribute has changed by clicking the ‘Open Attribute Table’ 
button in the tool bar and seeing if the attribute is listed there. 
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5.3 How to Add a New Attribute Column to an Attribute Table 
To add a new attribute column to the attribute table, in the Layers panel, right-click on the data 
layer > Open Attribute table or click on the ‘Open Attribute Table’ button in the tool menu 

 

 
 
 
 

 
1. Click the ‘Toggle Editing Mode’ button to allow editing 
2. Click the ‘New field’ button to add a new attribute 
3. In the Add Field menu, in the ‘Name’ field, type the name of the new attribute 
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4. In the ‘Type’ field, select the attribute data type. Possible Attribute data types: 

Data Types Description 
Whole Number (integer) Whole numbers (not decimals or fractions) 

that are positive or 0 only 
Whole Number (integer 64 bit) Whole numbers (not decimals or fractions) 

that are positive, negative or 0 only 
Decimal number (real) Positive or negative floating-point number. 

The length of the decimal includes the 
maximum number of digits allowed, while the 
precision specifies the number of numbers 
after the decimal point 

Text (string) A specified length of characters 
Date A date in the format YYYY-MM-DD 
Date & Time A date and time value of format YYYY-MM-

DD hh:mm:ss 
 

5. Define type-specific attributes (e.g. length = number of characters for a string) 
6. Click ‘OK’ 

 
7. Add values by double-clicking on cells and typing them in 
8. Re-click the ‘Toggle Editing Mode’ to re-toggle editing mode to save changes 
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5.4 How to Add a Calculated Field 
It is possible to create new attributes using values in existing attributes. To add a field to the 
attribute table this way, open the Attribute Table by pressing the ‘Open Attribute Table’ in 
the tool bar. 

 

 

 

 

 

 

 

 

 

 

1. Click the “Open Field Calculator” button 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
2. In the Field Calculator box, select the ‘Create a new field’ box 

• You can also select ‘Create virtual field’, but these fields are impermanent and will 
disappear once you close the project 

3. In the ‘Output field name’ field, enter a unique name of the new field you wish to 
generate (cannot create a new attribute with the same name of one that exists) 
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4. In the ‘Output field type’ field, select the datatype of the new field. Refer to Section 5.3 
for information on data types 

5. Under the ‘Expression’ tab, type in the expression that will calculate your new field 
• For example, to calculate the area of each feature, use the formula “$AREA”. If using 

the projection EPSG:3005/ NAD83 BC Albers, the units of the area field will be in m2. 
To convert to km2, divide by 1 000 000.  

6. In the Expression search window, under the option ‘Fields and Values’, you can select 
existing fields and add them to the expression 

7. Click ‘OK’ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

The new field should now appear in the attribute table. 
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6.0 Troubleshooting Common Issues in QGIS 
Below are solutions to five common and confusing issues that can come up in QGIS.  

6.1 Exporting Layers Error 
On attempting to save/export a layer, the following error appears: “Export to vector file failed. 
Error: Creation of layer failed (OGR error: failed to create file filename.shp: Permission 
denied)”. This occurs when the location to save the file is not specified. QGIS tries to save the 
file in the computer’s root folder, which is not allowed.  

 

 

To Fix: always use the ellipsis (three dots) to choose the file location before trying to save.  
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6.2 Geoprocessing Tool Does Not Work 
Another common error is when a clip, intersection, or other algorithm fails. Often this occurs 
when the two layers are not in the same projection.  
 
To Fix: When performing an operation on two or more layers, always make sure they are in the 
same projection.  
 
 
6.3 Layer in Wrong Location 
 
On import, a layer appears in the wrong location, or in no location at all (either the layer will 
appear in the wrong part of the world or will not appear on any base map). 
 

 

This polygon should be in Smithers, not the middle of the ocean! 

There are two common reasons this occurs: 

1. A point layer’s coordinates have been reversed (latitude and longitude mixed up) 
2. Any layer is being read in with the wrong projection 

 

To Fix: Some research may be required to determine the issue. If coordinates are reversed, this 
should be corrected. If an incorrect projection is being used, the correct projection must be 
determined and applied. 
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6.4 Tool Functions Not Working 
While trying to perform an operation on the attribute table, make an edit, identify a feature, 
etc., there is no response when attempting to perform the task. 

 
Often, this occurs because the wrong layer is selected. The selected layer is highlighted in the 
layer panel in blue or grey. In the screenshot below, the layer test_region is in edit mode, but 
the layer test_study_area is selected. The open attribute table button will open the attribute 
table of the test_study_area layer, not the test_region layer.  

 

 

To Fix: Ensure that the correct layer is selected in the Layers panel before making edits. 

 

 

6.5 QGIS is Being Unresponsive 
Sometime QGIS will not respond (i.e. a menu won’t open, an operation is failing, etc.). Although 
QGIS is generally very reliable, bugs do occur.  
 
To Fix: If an unexpected behaviour occurs, it is always worth saving the project and restarting 
QGIS. If this solves the issue, it was likely a bug that doesn’t need further attention from the 
user. 


